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ПОСТПРОЦЕССОР POST 

Постпроцессор предназначен для: 

 анимации результатов моделирования в реальном и модельном 

масштабе времени; 

 построения графиков изменения выходных переменных, в том 

числе фазовых; 

 создания таблиц результатов с возможностью их последующего 

экспорта в табличные процессоры и непосредственно в сам постпроцессор. 

 

Запуск постпроцессора 

Запуск постпроцессора осуществляется двойным щелчком мыши по 

иконке post  на рабочем столе или с помощью файла postprocessor.exe, 

находящегося в папке DINAMA\post\ (рисунок 1). 

 

Рисунок 1. Файл Postprocessor.exe 

Для чтения результатов моделирования необходимо открыть DAT-файл, 

содержащий результаты расчета вашей модели (File – Open) (рисунок 2). 



 

Рисунок 2. Выбор DAT-файла 

Если в задании на расчет указано несколько операторов выполнения 

задания, то для первого оператора результаты будут храниться в файле 

TEST.DAT, для последующих – соответственно TEST1.DAT, TEST2.DAT … 

Здесь TEST – имя файла задания. 

Для дальнейшей работы с DAT-файлом ниже приведено подробное 

описание функций постпроцессора.  



Описание функций постпроцессора. 

Приведем краткое описание всех пунктов меню. 

File 

File → Open 

 
 

Позволяет выбрать и открыть файл результатов расчёта. 

File → New diagram 

 
 

Открывает новое окно диаграммы. 

File → Save 

 

 

Сохраняет табличные данные графиков в файл. 



File → Save As 

 

 

Сохраняет табличные данные графиков в файл с указанным именем. 

File → Exit 

 

 

Осуществляет выход из постпроцессора. 

 

Edit 

Edit 

 

 

Это меню содержит три стандартные команды: Cut, Copy и Paste. 

Используются они при работе с табличными данными графиков. Также для 

этих команд есть кнопки на панели инструментов. 



View 

View 

 

 

Это меню, пункты которого (за исключением Undelete All

, который восстанавливает все объекты) становятся 

доступными при выделении какого-либо объекта в окне просмотра. У этого 

меню есть своя панель инструментов, слева в окне просмотра:  

View → Wireframe 

 
 

У выделенного объекта отображает только каркасное отображение. 

View →  Shading 

 
 

У выделенного объекта отображает залитое отображение. 



View →  Color 

 
 

 

У выделенного объекта задает  цвет. 

View →  Material 

  

 

У выделенного объекта определяет материал. 



View →  

Transparency 

    
 

У выделенного объекта определяет прозрачность от 0 до 10. 

View →  Delete 

    
 

Удаляет выделенный объект. 

  



Animation 

Это меню предназначено для управления анимацией в окне просмотра. У 

него есть своя панель инструментов в нижней части окна просмотра. 

 

Animation → Start 

 

 

Устанавливает просмотр на начальный момент времени. 

Animation → Back Step 

 

 

Делает один шаг назад по времени на величину указанную в поле Time 

Step на панели инструментов:  

 



Animation → Back 

 

 

Запускает анимацию назад по времени. 

Animation → Run 

 

 

Запускает анимацию. 

Animation → Forward step 

 

 

Запускает анимацию. 

Делает один шаг вперёд по времени на величину указанную в поле 

Time Step на панели инструментов:  



Animation → End 

 

 

Устанавливает просмотр на конечный момент времени. 

Animation → Stop 

 

 

 

Останавливает анимацию и возвращает в начальный момент времени. 

Animation → Pause 

 

 

 

Останавливает анимацию. 

Animation → Refresh 

 



 

 

То же самое, что и Stop. Если расчёт ещё не окончен, загружает 

новые данные. 

Так же, на панели инструментов присутствует ещё 3 неописанных 

объекта. 

 

Когда включено, анимация производится по реальному времени. 

Когда отключено, то по шагам расчёта. То есть, при включенном, аниматор 

пропускает какие-то шаги, или наоборот растягивает, чтобы 

синхронизировать реальное и расчётное время. А при выключенном, 

просто показывает все расчётные шаги подряд. 

 

Бегунок можно перемещать на любой нужный момент времени. 

Картинка анимации меняется соответственно положению бегунка. Так же 

можно задать момент времени точно с клавиатуры. 

 

Этот бегунок регулирует скорость анимации. 

 

Diagrams 

Это меню предназначено для работы с диаграммами. У него есть своя 

панель управления в верхней части окна диаграммы. 

 



Diagrams → Text table 

 

 

 

Открывает окно с табличными данными графиков изображённых в 

окне диаграммы. 

 

 

Diagrams → Curve 

selection 

 
 

 

Вызывает диалоговое окно. 



 

В нём можно выбирать, какие графики показывать (Y Group) и какую 

переменную откладывать по оси Х (X Group). Таким образом, существует 

возможность просматривать фазовые графики. 

Кнопка Select All выбирает все пункты в группе Y Group 

Кнопка Reset All убирает галочки во всех пунктах группы Y Group. 

Diagrams → Refresh 

 
 

 

Обновляет графики на диаграмме. То есть перерисовывает их с учётом 

последних данных, если расчёт ещё не был окончен. Так же этой командой 

можно пользоваться, если по каким-либо причинам изображение на диаграмме 

стало некорректным. 

Diagrams → Screen short 

 



 

 

Сохраняет картинку графиков в файл. 

Diagrams → Diagram 

Properties 

 
 

 

Вызывает диалоговое окно для настройки диаграмм. 

 

Так же на панели инструментов есть ещё один объект AutoScale: 

 

Когда AutoScale включено, все кривые рисуются именно в том масштабе, 

в каком они существуют в реальности. Когда отключено, то кривые, у которых 

не задан минимум и максимум, рисуются по-прежнему, а кривые, у которых 

минимум и максимум заданы, рисуются в заданных пределах, но нормируются 

от нуля. 



Внизу окна диаграммы показывается, какой цвет, какую кривую рисует. 

 

Если графиков больше двух, то этот список можно листать, чтобы 

увидеть названия всех нарисованных кривых. Нажав на названия кривой, 

можно вызвать её свойства. 

 

Параметры Min и Max задают минимум и максимум графика по оси Y, 

если установлена галочка справа от них. То есть позволяют масштабировать 

график. 

Кнопка Color позволяет выбирать цвет, которым рисуется график. 

Так же здесь можно менять название, стиль, толщину линии. Если 

открыто несколько окон с диаграммами, и в нескольких будет нарисован один 

график, то при смене свойств этого графика на одной диаграмме, 

автоматически будут меняться его свойства и на других диаграммах. Но 

увидеть это можно, только нажав Refresh на панели инструментов того окна, в 

котором Вы хотите увидеть эти новые свойства кривой.  



Settings 

 

Это меню содержит всего 

один пункт Options. Он вызывает 

диалоговое окно: 

 

 

Поле Deviation Coefficient определяет гладкость отрисовки элементов 

поверхностей второго порядка и выше. Например, эллипсов и сфер. Чем 

меньше коэффициент, тем красивее и более гладко рисуется объект. 

Пределы изменения: от 0.0001 до 0.1. Чем хуже качество отрисовки, тем 

выше производительность. 

 

Window 

 

Это стандартное меню для управления окнами. 



Help 

 

Это меню содержит всего один пункт. Он выводит информацию о ПП. 

 

Это все меню, которые есть ПП. 

  



PGO List 

Кроме всего перечисленного ПП имеет ещё 

одну возможность, управление ПГО. В правой 

части главного окна ПП расположено дочернее 

окно PGO List. 

Оно позволяет выбирать какие ПГО 

отображать в окне просмотра, а какие нет. 

Кнопка Update View отображает выбранные 

ПГО и убирает невыбранные. 

Кнопка Select All выбирает все ПГО. 

Кнопка Reset All убирает все ПГО. 

  

  



Создание видеоролика 

Создание видеороликов возможно с помощью панели инструментов 

Video Record Operations. Она располагается в верхней части 3D окна: 

 

 Команда Start Record позволяет начать запись фрагментов на диск. 

При этом пишется все изображение, находящееся в 3D окне: 3D объекты и 

любые изображения поверх окна, кроме курсора (например, подсказки).  

 Во время записи можно интерактивно манипулировать объектами, 

поворачивать, зуммировать, выполнять анимацию. Все, что происходит в окне, 

будет записано на диск, а в дальнейшем в видеоролик. Таким образом, можно 

записать не только анимацию решения, но и выполнить предварительный облет 

модели, с указанием наиболее интересных мест. 

 Для окончания записи требуется нажать на кнопку Stop Record.  

 

Конвертация изображений в видеоролик выполняется с помощью 

команды Save Record. При этом будет создан видеоролик с частотой 10 кадров в 

секунду (по умолчанию). 



 

Отображение модели 

На панели есть инструменты для изменения отображения модели так, как 

это удобно пользователю в данный момент.  

 

Команда FitAll  размещает модель полностью внутри окна. 

 

Команда Zoom Window позволяет выделить необходимую область модели, 

чтобы увеличить отображение определенной части, заключенной в эту область 

 

Команда Dynamic Zooming позволяет динамически менять размер 

отображаемой части модели 

 

Команды Zoom + и Zoom – приближают и отдаляют вид модели 

 

Команда Dynamic Panning  позволяет динамически перемещать модель 



 

Команда Global Panning глобально  перемещает модель 

 

Команды Front, Back, Top, Bottom, Left, Right, Axo размещают модель 

различными видами к пользователю 

 

Команда Dynamic Rotation динамически вращает модель  

 

Команда Reset сбрасывает все настройки отображения модели 

 

Команда Hidden Off и Hidden On отключает либо включает заполнение 

граней 

 

 



Многовариантный анализ 

 С помощью постпроцессора можно просмотреть результаты 

многовариантного анализа. А именно, графически отобразить файл истории.  

 

Загрузить файл истории можно с помощью команды History diagram 

меню Multi. В дальнейшем с загруженной диаграммой можно производить все 

те же действия, что и с обычной диаграммой: выбор графиков для просмотра, 

фазовые графики, создание таблицы значений, сохранение в виде картинки и 

т.д. 

Возможен импорт другого файла истории для сравнения. 

  



ПОСТПРОЦЕССИНГ И ГЕНЕРАЦИЯ ОТЧЕТОВ 

Создание инструмента по генерации отчетов в формате Excel 

Общая цель разработки инструмента по генерации отчетов по 

результатам моделирования в формате Excel заключалось в сокращении 

времени пользователей по обработке результатов и автоматическом их экспорте 

в общедоступные форматы офисных приложений, которые, в свою очередь, 

поддерживаются всеми основными PDM и PLM-системами. То есть данный 

инструмент позволяет подготовить конечные данные по анализу и работать с 

ними уже вне среды программного комплекса PRADIS. С помощью данного 

инструмента у разных специалистов появляется возможность (при наличии 

заранее подготовленной модели с внешними исходными данными) проводить 

автоматический анализ влияния тех или иных исходных данных без 

необходимости владения навыками и знаниями работы в самом программном 

комплексе PRADIS. 

Для реализации данного инструмента были созданы специальные 

компоненты для библиотеки «Report» - «DISPdata», «DISPExcelReport», 

«ExcelDiagram» и «POSTFunction». Данные компоненты совместно 

компонентом «Data» (см. таблицу 1) позволяют создавать, преобразовывать и 

экспортировать любые функции вывода, а также автоматически формировать 

их диаграммы в формате Excel. 

 

 

 

 

 

 



Таблица 1. Состав компонентов, применяемых для генерации отчетов в 

формате Excel  

№ 
Название 

компонента 

Изображен

ие компонента 
Описание компонента 

1

. 

Компонент 

Data 
 

Компонент описания 

данных 

2 
Компонент 

DISPdata 
 

Компонент настройки 

отображения диаграмм  

3 
Компонент 

DISPExcelReport 
 

Компонент генератор 

отчета в Excel 

4 
Компонент 

ExcelDiagram 
 

Компонент настройки 

параметров диаграмм в Excel 

(ограничение диаграммы по оси 

X и Y минимумы и максимумы, 

название осей и т.д.) 

 
Компонент 

POSTFunction  

Компонент постобработки 

функции 

 

Далее приведены описания ролей и параметров этих компонентов в 

процедуре генерации отчетов в формате Excel. 

Компонент DATA 

Компонент DATA предназначен для математического описания 

глобальных данных модели. В первую очередь, это описание констант и 

переменных и элементарных алгебраических операций с ними таких как, 

разность, сумма, возведение в квадрат, сумма квадратов, перевод радиан в 



градусы. Но стоит отметить, что ввод данных в компоненте «Data» может 

вестись на языке Python, что позволяет описывать сложные математические 

функции, которые невозможно описать при помощи простейшего 

алгебраического синтаксиса текстового редактора. 

Пример описания функций и их алгебраических операций приведен на 

рисунке 3.  

 

Рисунок 3. Пример заполнения поля компонента DATA 

  



Компонент DISPdata 

Компонент DISPdata предназначен для настройки параметров 

отображения диаграмм в постпроцессоре, таких как: 

 Название оси; 

 Выбор переменной оси; 

 Максимум/минимум границ оси; 

 Высота/ширина диаграмм. 

 

Рисунок 4. Пример заполнения строк заполнения компонента DISPdata 

Компонент DISPExcelReport 

Компонент DISPExcelReport служит для запуска непосредственно самой 

процедуры генерации отчета в формате Excel. 

В поле компонента необходимо заполнить следующие строки: 

 Report name – наименование отчета; 

ВАЖНО! Для корректного выполнения генерации отчета, его 

наименование должно быть написано с помощью латинского алфавита. 

 Result_File – результирующий файл расчетной модели; 

ВАЖНО! Результирующий файл должен иметь расширение .DAT; 



 File_Format – формат выводимого отчетного документа 

(Excel); 

 DISPdata object – выбор объекта отображения 

диаграмм (как правило объектом является компонент DISPdata); 

 Diagrams – выбор диаграмм которые в последующем 

будут включены в отчет. 

 

Рисунок 5. Пример заполнения строк заполнения компонента DISPExcelReport 

Компонент POSTFunction  

Компонент POSTFunction является функцией постобработки данных, 

полученных в результате анализа. 

В поле компонента необходимо заполнить следующие строки: 

 Function – объект функции (из ниспадающего меню 

необходимо выбрать объект функции user); 

 Parameters – в данной строке необходимо выбрать 

требуемую операцию для выполнения постобработки такие как, 

разность, сумма, возведение в квадрат, сумма квадратов, перевод 

радиан в градусы. Как правило, операции постобработки 

прописываются в компоненте DATA (см. пример описания 

компонента DATA); 

 VariableName – наименование переменной. 



 

Рисунок 6. Пример заполнения строк заполнения компонента POSTFunction 

Компонент ExcelDiagram  

Компонент ExcelDiagram является оператором обработки диаграммы, 

которая в последующем будет отражена в отчете Excel. 

В поле компонента необходимо заполнить следующий строки: 

 Description – наименование диаграммы (возможно 

использование кириллицы); 

 XCurve – переменная для оси X; 

 XCurveMin – минимум для оси X; 

 XCurveMax – минимум для оси X; 

 XCurveName – наименование оси X; 

 YCurveMin – минимум для оси Y; 

 YCurveMax – минимум для оси Y; 

 YCurveName – наименование оси Y; 

 Function – в данной строке необходимо указать 

функции (POSTFunction), которые необходимо включить в 

диаграмму. 

 



 

Рисунок 7. Пример заполнения строк заполнения компонента ExcelDiagram 

В качестве примера генерации отчета в формате Excel приводится 

процедура генерации отчета для расчетной модели кривошипно-шатунного 

механизма поршневого двигателя. Схема данной расчетной модели приведена 

на рисунке 8. 

 

Рисунок 8. Расчетная модель кривошипно-шатунного механизма поршневого двигателя 



После настройки всех вышеперечисленных компонентов расчетная 

модель по генерации отчетов в формате Excel как на рисунке 9. 

 

Рисунок 9. Пример расчетной модели по генерации отчетов в Excel 

При корректной настройке вышеописанной модели, после завершения 

процедуры расчета происходит запуск MS Excel со сгенерированным отчетом. 

В сгенерированном отчете формируются два листа:  

 Лист Dynamic1.res 

 Лист Dynamic1.plot 

На листе Dynamic1.res (рисунок 10) формируется таблица со всеми 

числовыми значениями, выводимых параметров расчетной модели, которые 

были настроены с помощью компонентов DISP. 



 

Рисунок 10. Пример листа Dynamic1.res в сгенерированном отчете 

На листе Dynamic1.plot (рисунок 11) формируются все диаграммы 

функций, которые были заданы с помощью компонентов DISP в самой 

расчетной модели, а также диаграммы функций, заданных с помощью 

компонентов модели генерации отчета, таких как POSTFunction. Параметры 

настроек самих этих диаграмм были определены при помощи компонентов 

DISPData (непосредственно в самой модели) и ExcelDiagram 

(непосредственно при генерации отчета). 



 

Рисунок 11. Пример листа Dynamic1.plot в сгенерированном отчете 

Рисунок 12. Пример диаграммы созданной с помощью компонентов модели генерации 

отчета 

 

 

 


